PPPoE là gì? HƯỚNG DẪN CẤU HÌNH PPPoE Đơn Giản Nhất

1. PPPoE là gì?

Nhà cung cấp dịch vụ Internet hay Nhà cung cấp dịch vụ nối mạng (tiếng Anh: Internet Service Provider, viết tắt: ISP) chuyên cung cấp các giải pháp kết nối mạng toàn cầu (Internet) cho các đơn vị tổ chức hay các cá nhân người dùng.

PPPoE (Point to Point Protocol over Ethernet) Nó xuất hiện vào năm 1999, trong bối cảnh sự bùng nổ của DSL như một giải pháp cho đường hầm các gói qua kết nối DSL tới mạng IP của ISP, là một giao thức mạng với được hình thành bởi sự đóng gói dữ liệu của gói tin PPP trong gói tin Ethernet, Hầu hết các nhà cung cấp DSL sử dụng PPPoE. Việc sử dụng PPPoE điển hình liên quan đến việc tận dụng các cơ sở PPP để xác thực người dùng bằng tên người dùng và mật khẩu, chủ yếu thông qua giao thức PAP(Password Authentication Protocol:Giao thức xác thực mật khẩu) và ít thường xuyên hơn qua CHAP(Challenge-Handshake Authentication Protocol:Giao thức xác thực bắt tay thử thách).

PPPoE được phát triển bởi UUNET , Redback Networks và RouterWare ( Wind River Systems ) và có sẵn như là một thông tin RFC 2516.

PPPoE hy vọng sẽ hợp nhất cơ sở hạ tầng Ethernet rộng rãi với PPP phổ biến, cho phép các nhà cung cấp sử dụng lại phần mềm hiện có của họ và cung cấp sản phẩm trong thời gian rất gần. Về cơ bản, tất cả các hệ điều hành vào thời điểm đó đều có một ngăn xếp PPP và thiết kế của PPPoE cho phép một đoạn mã đơn giản ở giai đoạn mã hóa đường truyền để chuyển đổi từ PPP sang PPPoE.

2. Hướng dẫn cấu hình PPPoE đơn giản nhất

2.1. Mô hình (Mình kéo thả nhanh bằng eve)

PPPoE

2.2. Cấu hình PPPoE trên Cisco Router

Đầu tiên ta cấu hình Port e0/0 của Router-Internet

>>> Xem thêm

Dịch vụ cho thuê thiết bị CNTT

Interface e0/0

  • Description Connect to LAN
  • ip address 192.168.10.1 255.255.255.0
  • ip nat inside             //Khai báo thông số NAT
  • ip tcp adjust-mss 1452 //phải có thông sô này để cân bằng MTU
  • Port e0/1 sẽ kết nối từ converter đường FTTH vào và ta sẽ quay PPPoE

Interface e0/1

  • Description connect to FTTH
  • no ip address
  • pppoe enable group global
  • pppoe-client dial-pool-number 1
  • Cấu hình tiếp interface dialer 1 và thông số PPPoE sẽ được config ở đây

interface Dialer1

  • Description Information for setting PPPoE
  • mtu 1492 //Khai báo thông số mtu
  • ip address negotiated
  • ip nat outside //Khai báo thông số NAT
  • encapsulation ppp
  • dialer pool 1
  • dialer-group 1
  • ppp authentication pap callin
  • ppp pap sent-username <USERNAME> password <PASSWORD>
  • ppp ipcp dns request
  • ppp ipcp route default
Xem thêm:
» Dịch vụ cho thuê laptop giá rẻ cấu hình đa dạng
» Cho thuê PC Gaming cấu hình mạnh

2.3. Khai báo thông số route

  • Ta tạo default route ra cổng dialer 1, mô hinh ở đây đơn giản chỉ co 1 network, nếu có nhiều network thì phải tạo static route về các network này
  • ip route 0.0.0.0 0.0.0.0 Dialer1

2.4. Khai báo DNS Server

  • ip name-server 8.8.8.8
  • ip name-server <DNS-Server 02>
  • ip name-server <DNS-Server 03>

2.5. Khai báo NAT Dynamic với network Users

  • Khai báo trước access-list cho lớp mạng users
  • access-list 1 permit 192.168.10.0 0.0.0.255
  • ip nat inside source list 1 interface Dialer1 overload
  • Sau khi add lệnh này xong thì tiến hành gõ lệnh bên dưới để xem các session đã NAT ra được chưa
  • show ip nat translations //xem session NAT

2.6. Khai báo NAT static với server WEB

  • Khai báo theo câu lệnh bên dưới để NAT 1:1 đối với server web với port 80 và 443
  • ip nat inside source static tcp 192.168.10.253 80 interface Ethernet0/1 80
  • ip nat inside source static tcp 192.168.10.253 443 interface Ethernet0/1 443

>>>Xem thêm : Các Bước Cấu Hình RAID Trên Server IBM X3650 M4

Xem Thêm: Hướng Dẫn Lab Cấu Hình PPPoE va InterVlanRouting trên Router Cisco


Anh/Chị có thắc mắc hỏi đáp hay Góp ý gì xin vui lòng đặt câu hỏi tại Group Facebook Hỗ trợ TẠI ĐÂY

10 bình luận
  1. Cảm ơn ad về hướng dẫn cấu hình switch cisco, hiện tại mình làm theo để cài cho Hap AC2.
    Nhưng có vấn đề: ppoe trên AC2 ok, ping từ AC2 ra Internet được.
    Nhưng kết nối với PC thì PC lại không có internet access, làm đi làm lại mấy lần nó vẫn vậy ad ơi

    • Cảm ơn bạn đã đóng góp ý về cho page ạ!
      Lỗi bạn đang gặp do bạn chưa thực hiện tới bước NAT PPPoE hoặc chưa cài đặt DHCP Server hoặc cài đặt DNS. Bạn hãy tham khảo qua các bước để kiểm tra lỗi và khắc phục.
      Chúc bạn sớm khắc phục lỗi thành công.

  2. Mình đã làm theo hướng dẫn cấu hình router cisco nhưng không được?

    • Chào bạn ạ!
      Bạn vui lòng cho mình xin thêm thông tin bạn không cấu hình pppoe trên router cisco cụ thể như thế nào, máy báo lỗi hay có hiện tượng ra sao để mình kiểm tra hỗ trợ bạn nhé.
      Mong nhận được phản hồi từ bạn.

  3. Cấu hình pppoe mikrotik cũ của vnpt m xài bth, hôm nay báo lỗi “terminating – failed to authenticate ourselves to peer:. Mong ad giúp ạ!

    • Cảm ơn bạn đã đóng góp ý. Lỗi bạn đang gặp phải do sai thông tin tài khoản giao thức PPPoE hoặc số lượng kết nối PPPoE đã vượt quá giới hạn trên hệ thống nhà cung cấp dịch vụ.
      Chúc bạn cấu hình pppoe mikrotik thành công.

  4. Khi quay pppoe nếu có 1 dãy ip public thì muốn router quay 1 số ip public cố định thì làm thế nào vậy ad? Rồi tùy chỉnh ip allias khi NAT port trong dãy ip public đó nửa?

    • Cảm ơn bạn đã đóng góp ý.
      Rất tiếc, thông tin ad nhận của bạn chưa cụ thể nên ad chưa thể hỗ trợ bạn trong vấn đề này được ạ.
      Chúc bạn có những trải nghiệm tuyệt vời cùng sản phẩm Mikrotik.
      Thân chào bạn ạ.

  5. Sau khi cấu hình router cisco ra internet chạy 3 wan như trên thì băng thông gộp lại như thế nào anh?

    • Cảm ơn bạn đã đóng góp ý về Page ạ.
      Sau khi thực hiện cấu hình pppoe trên router cisco cân bằng tải, giá trị băng thông nhận được chính là giá trị băng thông của các đường Internet bạn đang có.
      Thân chào bạn ạ.

Bình luận của bạn
Sản phẩm

CHÍNH HÃNG

Giao hàng tận nơi

63 TỈNH THÀNH

Lắp đặt miễn phí

HN & TPHCM

Bảo hành dài hạn

Bảo hành 24 tháng

0906652739